[MorpheusX] Attachment mod

Specific instructions on how to apply certain mods to certain styles.

Moderator: Moderators

[MorpheusX] Attachment mod

Postby minaskin on Thu Dec 30, 2004 10:58 am

i install attach_mod in MorpheusX

then when i try to place {postrow.ATTACHMENTS} after {postrow.MESSAGE} in
viewtopic_post_above.tpl
viewtopic_post_left.tpl
viewtopic_post_right.tpl
viewtopic_post_none.tpl

but it doesn't work, someone know why ?
User avatar
minaskin
Registered User
Registered User
 
Posts: 28
Joined: Tue Dec 28, 2004 8:00 am

Postby PostBot on Thu Dec 30, 2004 11:22 am

edit: solution removed because it doesn't work as intended. see minaskin's solution below
Do NOT pm me, I don't visit this forum anymore, don't own it, don't provide any support and don't moderate.
User avatar
PostBot
Moderator
Moderator
 
Posts: 10659
Joined: Sat Aug 02, 2003 3:52 pm
Location: Mars

Postby minaskin on Thu Dec 30, 2004 12:32 pm

i just try it but it seems don't work :?
User avatar
minaskin
Registered User
Registered User
 
Posts: 28
Joined: Tue Dec 28, 2004 8:00 am

Postby PostBot on Thu Dec 30, 2004 12:55 pm

ok. I've got one forum with attachment mod and will test it in a few hours then will post solution.
Do NOT pm me, I don't visit this forum anymore, don't own it, don't provide any support and don't moderate.
User avatar
PostBot
Moderator
Moderator
 
Posts: 10659
Joined: Sat Aug 02, 2003 3:52 pm
Location: Mars

Postby minaskin on Thu Dec 30, 2004 1:02 pm

thank CA, i will wait for it :)
User avatar
minaskin
Registered User
Registered User
 
Posts: 28
Joined: Tue Dec 28, 2004 8:00 am

Postby mkot on Fri Dec 31, 2004 3:46 am

same here
I will wait for it too :)
User avatar
mkot
Registered User
Registered User
 
Posts: 154
Joined: Fri Nov 05, 2004 8:06 am
Location: doh

Postby minaskin on Fri Dec 31, 2004 6:33 am

ok i think i found it
i post here with CA's modifs

Code: Select all
#
#-----[ OPEN ]------------------------------------------------
#
templates/MorpheusX/viewtopic_body.tpl

#
#-----[ FIND ]------------------------------------------------
#
</table>

{POLL_DISPLAY}

#
#-----[ AFTER, ADD ]------------------------------------------
#
<!-- BEGIN postrow -->

#
#-----[ FIND ]------------------------------------------------
#
$postrow_item['TPL_CLASS_PROFILE'] = 'post-left' . $num;

#
#-----[ AFTER, ADD ]------------------------------------------
#
ob_start(); 
   ?>{postrow.ATTACHMENTS}<?php 
   $postrow_item['ATTACHMENTS'] = ob_get_contents(); 
   ob_end_clean(); 

#
#-----[ FIND ]------------------------------------------------
#
}   
?>

#
#-----[ AFTER, ADD ]------------------------------------------
#
<!-- END postrow -->
User avatar
minaskin
Registered User
Registered User
 
Posts: 28
Joined: Tue Dec 28, 2004 8:00 am

Postby mistermo on Sat Jan 01, 2005 8:44 pm

okay i do this what minaskin postet and in all viewtopic_post_*.tpl is use {postrow.TPL_ATTACHMENTS} after postrwo.MESSAGE...
but it doesn't work :( can someone poste die needed files view* and so ?

thank you !
greetz from germany :D
mistermo
Registered User
Registered User
 
Posts: 3
Joined: Fri Dec 31, 2004 5:10 pm

Postby Greg on Sat Jan 01, 2005 10:02 pm

yeah, I am having problems with the attachment mod, can someone post theirs.

Thanks,
Greg
User avatar
Greg
Registered User
Registered User
 
Posts: 651
Joined: Wed Jul 07, 2004 3:20 pm
Location: Yorkshire, United Kingdom

Postby minaskin on Sun Jan 02, 2005 10:28 am

with my modifs u dont need replace in viewtopic_post_*.tpl {postrow.TPL_ATTACHMENTS} instead of {postrow.ATTACHMENTS}, just keep {postrow.ATTACHMENTS}
User avatar
minaskin
Registered User
Registered User
 
Posts: 28
Joined: Tue Dec 28, 2004 8:00 am

Postby mistermo on Sun Jan 02, 2005 3:44 pm

WUUUHHAAAAAAAA i become crazy ;) yeah thanx a lot ;)
mistermo
Registered User
Registered User
 
Posts: 3
Joined: Fri Dec 31, 2004 5:10 pm

Postby Subz on Sun Jan 02, 2005 9:45 pm

[quote user="minaskin" post="11725"]ok i think i found it
i post here with CA's modifs

Code: Select all
#
#-----[ OPEN ]------------------------------------------------
#
templates/MorpheusX/viewtopic_body.tpl

#
#-----[ FIND ]------------------------------------------------
#
</table>

{POLL_DISPLAY}

#
#-----[ AFTER, ADD ]------------------------------------------
#
<!-- BEGIN postrow -->

#
#-----[ FIND ]------------------------------------------------
#
$postrow_item['TPL_CLASS_PROFILE'] = 'post-left' . $num;

#
#-----[ AFTER, ADD ]------------------------------------------
#
ob_start(); 
   ?>{postrow.ATTACHMENTS}<?php 
   $postrow_item['ATTACHMENTS'] = ob_get_contents(); 
   ob_end_clean(); 

#
#-----[ FIND ]------------------------------------------------
#
}   
?>

#
#-----[ AFTER, ADD ]------------------------------------------
#
<!-- END postrow -->
[/quote]


i did this to view topic and attachemtn is not show up, any ideas what i did wrong?
User avatar
Subz
Registered User
Registered User
 
Posts: 924
Joined: Sat Aug 21, 2004 12:54 am
Location: North London

Postby PostBot on Sun Jan 02, 2005 9:47 pm

As minaskin wrote above - don't change {postrow.ATTACHMENTS} to {postrow.TPL_ATTACHMENTS}
Do NOT pm me, I don't visit this forum anymore, don't own it, don't provide any support and don't moderate.
User avatar
PostBot
Moderator
Moderator
 
Posts: 10659
Joined: Sat Aug 02, 2003 3:52 pm
Location: Mars

Postby Subz on Sun Jan 02, 2005 9:48 pm

[quote user="CyberAlien" post="12175"]As minaskin wrote above - don't change {postrow.ATTACHMENTS} to {postrow.TPL_ATTACHMENTS}[/quote]

but all i did in view topic was the code above i haven't done anythink else
User avatar
Subz
Registered User
Registered User
 
Posts: 924
Joined: Sat Aug 21, 2004 12:54 am
Location: North London

Postby Gargoyle on Sun Jan 02, 2005 11:06 pm

This is how my file looks after the changes mentioned above and it does not work ???

Code: Select all
   // check for new post
   $new_post = strpos($postrow_item['MINI_POST_IMG'], '_new') > 0 ? true : false;
   $postrow_item['TPL_HDR1'] = $new_post ? $this->vars['TPL_HDR1_NEW'] : $this->vars['TPL_HDR1_POST'];
   $postrow_item['TPL_HDR2'] = $new_post ? $this->vars['TPL_HDR2_NEW'] : $this->vars['TPL_HDR2'];
   $postrow_item['TPL_FTR'] = $new_post ? $this->vars['TPL_FTR_NEW'] : $this->vars['TPL_FTR'];
   // set backgrounds
   $num = ($postrow_i % 2) + 1;
   $postrow_item['TPL_CLASS_POST'] = 'post' . $num;
   $postrow_item['TPL_CLASS_PROFILE'] = 'post-left' . $num;
   ob_start();   
     ?>{postrow.ATTACHMENTS}<?php   
     $postrow_item['ATTACHMENTS'] = ob_get_contents();   
     ob_end_clean();   
User avatar
Gargoyle
Registered User
Registered User
 
Posts: 52
Joined: Sun Jan 02, 2005 6:13 pm

Next

Return to How to mod some styles

Who is online

Users browsing this forum: No registered users and 1 guest

cron